Tuesday, 8 January 2019

compilesdkversion 'android-26' requires jdk 1.8 or later to compile visual studio


You are getting the build error in the Android Apache Cordova.

>compilesdkversion 'android-26' requires jdk 1.8 or later to compile visual studio

You  are getting this error as your application is not pointing to the valid version of the  java SDK (JDK) 

You need to set the JAVA SDK version from below screen in visual Studio.

Tools > Option > Tools for Apache Cordova  > Environment Variable Override


From there you can update the Android Home, Jana Home, GIT Home

Update Java Home Versions like below, checked the checkbox.

  
Build your application.



4 comments: